source: debian/gutenbach-remctl.postinst @ c95ca32

debian
Last change on this file since c95ca32 was c95ca32, checked in by Kyle Brogle <broglek@…>, 14 years ago

Changed postinst of gutenbach-remctl so that debconf vars are actually saved

  • Property mode set to 100644
File size: 1.9 KB
Line 
1#!/bin/sh
2# postinst script for gutenbach-remctl
3#
4# see: dh_installdeb(1)
5
6set -e
7. /usr/share/debconf/confmodule
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20case "$1" in
21    configure|reconfigure)
22
23        if [ ! -d /usr/lib/gutenbach/remctl/config ]; then
24            mkdir /usr/lib/gutenbach/remctl/config
25        fi
26       
27        db_get gutenbach-remctl/mixer
28        echo "$RET" > /usr/lib/gutenbach/remctl/config/mixer
29        db_get gutenbach-remctl/channel
30        echo "$RET" > /usr/lib/gutenbach/remctl/config/channel
31
32        chmod +x /usr/lib/gutenbach/remctl/cd-cddb
33        chmod +x /usr/lib/gutenbach/remctl/cd-cddb-get
34        chmod +x /usr/lib/gutenbach/remctl/cd-play
35        chmod +x /usr/lib/gutenbach/remctl/status-clear
36        chmod +x /usr/lib/gutenbach/remctl/status-get
37        chmod +x /usr/lib/gutenbach/remctl/volume-down
38        chmod +x /usr/lib/gutenbach/remctl/volume-get
39        chmod +x /usr/lib/gutenbach/remctl/volume-help
40        chmod +x /usr/lib/gutenbach/remctl/volume-is-muted
41        chmod +x /usr/lib/gutenbach/remctl/volume-mute
42        chmod +x /usr/lib/gutenbach/remctl/volume-set
43        chmod +x /usr/lib/gutenbach/remctl/volume-show
44        chmod +x /usr/lib/gutenbach/remctl/volume-up
45        chmod +x /usr/lib/gutenbach/remctl/volume-zephyr
46    ;;
47
48    abort-upgrade|abort-remove|abort-deconfigure)
49    ;;
50
51    *)
52        echo "postinst called with unknown argument \`$1'" >&2
53        exit 1
54    ;;
55esac
56
57# dh_installdeb will replace this with shell code automatically
58# generated by other debhelper scripts.
59
60#DEBHELPER#
61
62exit 0
Note: See TracBrowser for help on using the repository browser.