source: web/old/remctl-2.14/remctl.spec @ f6f3e91

web
Last change on this file since f6f3e91 was f6f3e91, checked in by Jessica B. Hamrick <jhamrick@…>, 15 years ago

Preserve directory hierarchy (not sure what happened to it)

  • Property mode set to 100644
File size: 6.4 KB
Line 
1%define rel %(cat /etc/redhat-release | cut -d' ' -f7)
2
3# Use rpmbuild option "--define 'buildperl 0'" to not build the Perl module.
4%{!?buildperl:%define buildperl 1}
5
6Name: remctl
7Summary: Client/server for Kerberos-authenticated command execution
8Version: 2.13
9Release: 1.EL%{rel}
10Copyright: MIT
11URL: http://www.eyrie.org/~eagle/software/remctl/
12Source: http://archives.eyrie.org/software/kerberos/%{name}-%{version}.tar.gz
13Group: System Environment/Daemons
14Vendor: Stanford University
15Packager: Russ Allbery <rra@stanford.edu>
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: krb5-devel
18Distribution: EL
19
20%ifarch x86_64
21%define ldir /usr/lib64
22%else
23%define ldir /usr/lib
24%endif
25
26%description
27remctl is a client/server protocol for executing specific commands on a
28remote system with Kerberos authentication.  The allowable commands must
29be listed in a server configuration file, and the executable run on the
30server may be mapped to any command name.  Each command is also associated
31with an ACL containing a list of Kerberos principals authorized to run
32that command.
33
34%package server
35Summary: Server for Kerberos-authenticated command execution
36Group: System Environment/Daemons
37
38%description server
39remctl is a client/server protocol for executing specific commands on a
40remote system with Kerberos authentication.  The allowable commands must
41be listed in a server configuration file, and the executable run on the
42server may be mapped to any command name.  Each command is also associated
43with an ACL containing a list of Kerberos principals authorized to run
44that command.
45
46This package contains the server (remctld).
47
48%package client
49Summary: Client for Kerberos-authenticated command execution
50Group: Applications/Internet
51
52%description client
53remctl is a client/server protocol for executing specific commands on a
54remote system with Kerberos authentication.  The allowable commands must
55be listed in a server configuration file, and the executable run on the
56server may be mapped to any command name.  Each command is also associated
57with an ACL containing a list of Kerberos principals authorized to run
58that command.
59
60This package contains the client program (remctl) and the client libraries.
61
62%prep
63%setup -n remctl-%{version}
64
65%build
66options="--prefix=/usr --mandir=/usr/share/man --sysconfdir=/etc/remctl"
67%if %{buildperl}
68options="$options --enable-perl"
69%endif
70PATH="/sbin:/bin:/usr/sbin:$PATH" \
71%configure $options
72%{__make}
73
74%install
75%{__rm} -rf %{buildroot}
76%makeinstall
77mkdir -p %{buildroot}/etc/xinetd.d
78install -c -m 0644 examples/xinetd %{buildroot}/etc/xinetd.d/remctl
79mkdir -p %{buildroot}/etc/remctl/acl
80mkdir -p %{buildroot}/etc/remctl/conf.d
81install -c -m 0644 examples/remctl.conf %{buildroot}/etc/remctl/remctl.conf
82%ifarch x86_64
83if [ -d %{buildroot}/usr/lib/ ]; then
84    mv %{buildroot}/usr/lib/ %{buildroot}/%{ldir}
85fi
86%endif
87%if %{buildperl}
88find %{buildroot} -name perllocal.pod -exec rm {} \;
89%endif
90
91%files client
92%defattr(-, root, root, 0755)
93%{_bindir}/*
94%defattr(0644, root, root)
95%doc NEWS README TODO
96/usr/include/remctl.h
97%{ldir}/libremctl.a
98%{ldir}/libremctl.la
99%{ldir}/libremctl.so.1.0.0
100%{_mandir}/*/remctl.*
101%{_mandir}/*/remctl_*
102%if %{buildperl}
103%{ldir}/perl5/site_perl/
104%{_mandir}/*/Net::Remctl.3pm*
105%endif
106
107%files server
108%defattr(-, root, root, 0755)
109%{_sbindir}/*
110%defattr(0644, root, root)
111%doc NEWS README TODO
112%{_mandir}/*/remctld.*
113/etc/xinetd.d/remctl
114%dir /etc/remctl/
115%defattr(0640, root, root)
116%config(noreplace) /etc/remctl/remctl.conf
117%defattr(0755, root, root)
118%dir /etc/remctl/acl/
119%defattr(0750, root, root)
120%dir /etc/remctl/conf.d/
121
122%post client
123/sbin/ldconfig
124
125%post server
126# If this is the first remctl install, add remctl to /etc/services and
127# restart xinetd to pick up its new configuration.
128if [ "$1" = 1 ] ; then
129    if grep -q '^remctl' /etc/services ; then
130        :
131    else
132        echo 'remctl    4373/tcp' >> /etc/services
133    fi
134    if [ -f /var/run/xinetd.pid ] ; then
135        kill -HUP `cat /var/run/xinetd.pid`
136    fi
137fi
138
139%postun client
140/sbin/ldconfig
141
142%postun server
143# If we're the last remctl package, remove the /etc/services line and
144# restart xinetd to reflect its new configuration.
145if [ "$1" = 0 ] ; then
146    if [ ! -f /usr/sbin/remctld ] ; then
147        if grep -q "^remctl" /etc/services ; then
148            grep -v "^remctl" /etc/services > /etc/services.tmp
149            mv -f /etc/services.tmp /etc/services
150        fi
151        if [ -f /var/run/xinetd.pid ] ; then
152            kill -HUP `cat /var/run/xinetd.pid`
153        fi
154    fi
155fi
156
157%clean
158%{__rm} -rf %{buildroot}
159
160%changelog
161* Fri Nov 14 2008 Russ Allbery <rra@stanford.edu> 2.13-1
162- Update for 2.13.
163- PHP and Python bindings not yet supported.
164
165* Fri Apr 4 2008 Russ Allbery <rra@stanford.edu> 2.12-1
166- Update for 2.12.
167
168* Fri Nov 9 2007 Russ Allbery <rra@stanford.edu> 2.11-1
169- Update for 2.11.
170- Change port configuration to 4373.
171
172* Sun Aug 26 2007 Russ Allbery <rra@stanford.edu> 2.10-1
173- Update for 2.10.
174- Incorporate changes by Darren Patterson to install the Perl module.
175
176* Sun Mar 25 2007 Russ Allbery <rra@stanford.edu> 2.7-1
177- Update for 2.7.
178
179* Sat Feb 3 2007 Russ Allbery <rra@stanford.edu> 2.6-1
180- Update for 2.6.
181
182* Sat Feb 3 2007 Russ Allbery <rra@stanford.edu> 2.5-1
183- Update for 2.5.
184- Incorporate changes by Darren Patterson to split into subpackages for
185  client and server and remove krb5-workstation requirement.
186
187* Wed Jan 17 2007 Russ Allbery <rra@stanford.edu> 2.4-1
188- Update for 2.4.
189- Changed permissions on the ACL directory to allow any user read.
190- Added fix for /usr/lib64 directory on x86_64.
191
192* Tue Aug 22 2006 Russ Allbery <rra@stanford.edu> 2.1-1
193- Update for 2.1.
194- Incorporate changes by Digant Kasundra and Darren Patterson to the
195  Stanford-local RPM spec file, including looking for libraries in the
196  correct path, creating the /etc/remctl structure, running ldconfig,
197  and handling library installation properly.
198- Build remctl to look in /etc/remctl/remctl.conf for its config.
199- Install the examples/remctl.conf file as /etc/remctl/remctl.conf.
200
201* Mon Aug  7 2006 Russ Allbery <rra@stanford.edu> 2.0-1
202- New upstream release that now provides a library as well.
203- Add TODO to documentation files.
204
205* Fri Mar 24 2006 Russ Allbery <rra@stanford.edu> 1.12-3
206- Lots of modifications based on the contributed kstart spec file.
207- Use more internal RPM variables.
208- Borrow the description from the Debian packages.
209
210* Sun Feb 19 2006 Digant C Kasundra <digant@stanford.edu> 1.12-2
211- Initial version.
Note: See TracBrowser for help on using the repository browser.