source: debian/sipbmp3.postinst @ 2babe17

debianmacno-cupsnodebathenaweb
Last change on this file since 2babe17 was 2babe17, checked in by Jessica Hamrick <jhamrick@…>, 16 years ago

Installing the debian package should make the printing of music files
to the lprmp3 printer work. Still need to add in support for uninstalling
the package and using debconf (so users can add in their own configuration)

  • Property mode set to 100644
File size: 1.3 KB
Line 
1#!/bin/sh
2# postinst script for sipbmp3
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        chmod +x /usr/lib/sipbmp3/inst/edit-printcap
24        chmod +x /usr/lib/sipbmp3/inst/edit-lpd.conf
25        chmod +x /usr/lib/sipbmp3/inst/run-checkpc
26        chmod +x /usr/lib/sipbmp3/inst/edit-lpd.perms
27        /usr/lib/sipbmp3/inst/edit-printcap
28        /usr/lib/sipbmp3/inst/edit-lpd.conf
29        /usr/lib/sipbmp3/inst/run-checkpc
30        /usr/lib/sipbmp3/inst/edit-lpd.perms
31
32        adduser daemon audio
33        adduser daemon pulse
34    ;;
35
36    abort-upgrade|abort-remove|abort-deconfigure)
37    ;;
38
39    *)
40        echo "postinst called with unknown argument \`$1'" >&2
41        exit 1
42    ;;
43esac
44
45# dh_installdeb will replace this with shell code automatically
46# generated by other debhelper scripts.
47
48#DEBHELPER#
49
50exit 0
Note: See TracBrowser for help on using the repository browser.