[632040d] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for gutenbach-remctl |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
[2116615] | 7 | . /usr/share/debconf/confmodule |
---|
[632040d] | 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | case "$1" in |
---|
| 21 | configure|reconfigure) |
---|
| 22 | chmod +x /usr/lib/gutenbach/remctl/cd-cddb |
---|
| 23 | chmod +x /usr/lib/gutenbach/remctl/cd-cddb-get |
---|
| 24 | chmod +x /usr/lib/gutenbach/remctl/cd-play |
---|
| 25 | chmod +x /usr/lib/gutenbach/remctl/status-clear |
---|
| 26 | chmod +x /usr/lib/gutenbach/remctl/status-get |
---|
| 27 | chmod +x /usr/lib/gutenbach/remctl/volume-down |
---|
| 28 | chmod +x /usr/lib/gutenbach/remctl/volume-get |
---|
| 29 | chmod +x /usr/lib/gutenbach/remctl/volume-help |
---|
| 30 | chmod +x /usr/lib/gutenbach/remctl/volume-is-muted |
---|
| 31 | chmod +x /usr/lib/gutenbach/remctl/volume-mute |
---|
| 32 | chmod +x /usr/lib/gutenbach/remctl/volume-set |
---|
| 33 | chmod +x /usr/lib/gutenbach/remctl/volume-show |
---|
| 34 | chmod +x /usr/lib/gutenbach/remctl/volume-up |
---|
| 35 | chmod +x /usr/lib/gutenbach/remctl/volume-zephyr |
---|
| 36 | ;; |
---|
| 37 | |
---|
| 38 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 39 | ;; |
---|
| 40 | |
---|
| 41 | *) |
---|
| 42 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 43 | exit 1 |
---|
| 44 | ;; |
---|
| 45 | esac |
---|
| 46 | |
---|
| 47 | # dh_installdeb will replace this with shell code automatically |
---|
| 48 | # generated by other debhelper scripts. |
---|
| 49 | |
---|
| 50 | #DEBHELPER# |
---|
| 51 | |
---|
| 52 | exit 0 |
---|