debianmacno-cupsweb
Last change
on this file since ee42199 was
e87e682,
checked in by Jessica B. Hamrick <jhamrick@…>, 14 years ago
|
Move debian folder into the root, and move all non-debian code into gutenbach-queue/
|
-
Property mode set to
100644
|
File size:
1.4 KB
|
Rev | Line | |
---|
[39452be] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for gutenbach-queue |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | . /usr/share/debconf/confmodule |
---|
| 21 | |
---|
| 22 | case "$1" in |
---|
| 23 | configure|reconfigure) |
---|
| 24 | chmod +x /usr/lib/gutenbach/queue/build-gutenbach-queue |
---|
| 25 | chmod +x /usr/lib/gutenbach/queue/kill-gutenbach-queue |
---|
[8de196a] | 26 | chmod +x /usr/lib/gutenbach/queue/view-gutenbach-queue |
---|
| 27 | chmod +x /usr/lib/gutenbach/queue/queue |
---|
| 28 | |
---|
| 29 | if [ ! -e /usr/bin/view-gutenbach-queue ]; then |
---|
| 30 | ln -s /usr/lib/gutenbach/queue/view-gutenbach-queue /usr/bin/view-gutenbach-queue |
---|
| 31 | fi |
---|
| 32 | |
---|
[42b3872] | 33 | chown -R daemon:daemon /var/run/gutenbach |
---|
[97c17a0] | 34 | chmod og+rw /var/run/gutenbach |
---|
[39452be] | 35 | ;; |
---|
| 36 | |
---|
| 37 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 38 | ;; |
---|
| 39 | |
---|
| 40 | *) |
---|
| 41 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 42 | exit 1 |
---|
| 43 | ;; |
---|
| 44 | esac |
---|
| 45 | |
---|
| 46 | # dh_installdeb will replace this with shell code automatically |
---|
| 47 | # generated by other debhelper scripts. |
---|
| 48 | |
---|
| 49 | #DEBHELPER# |
---|
| 50 | |
---|
| 51 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.